All of javascript is kinda just pretend.
All of javascript is kinda just pretend.
CVS is gonna make a comeback! I tell ya!
In the case of this gist, it’s premature optimization. Generally it’s necessary cuz new implementations come along often.
That sounds terribly inexperienced. That’s exactly what updates to code are for. You cannot manage all kind of, sort of similar but different libraries with one code base. It would be horrific to even consider it.
By embedding the class, creates a limitation that prevents abstractions or other implementations of each component. Imagine every suggestion in this conversation thread is another variation with a separate implementation.
If the user wanted to create a new FoldableDockWidget
with a different title bar, they’d extend the FoldableDockWidget
class and override the Titlebar method in their extension of it. I understand your point, but isn’t it over optimisation?
The widget class belongs to the FoldableDockWidget class until it doesn’t. Then a refactor is needed.
One line of instantiating code. I can’t imagine where or how the custom title bar would be used outside of the Foldable Dock Widget class though. That’s probably the real reason why I made it a sub class. Not how I’d do it in other languages, but in Python? I’m trying it out!
Hardwiring a particular implementation of the Windowing python wrapper is necessary. They have slightly different implementations. If something magically new comes along, then, the code is updated. Again, over optimisation here which is unnecessary.
The code in the process guard is just sample code to demonstrate use of the class. No big deal. It’s separate to the class and not to be imported because… this is a gist of sample code!
Thanks for the compliment! Python isn’t my first language and it’s difficult to be able to switch style from one language to another!
I always find it difficult to choose when to use ternary statements. Sometimes, for something quick and simple, I will, otherwise I’ll be explicit. This is more of a readability issue than anything else. And I find the ternary statements quite verbose compared to other languages by using the words if/else rather than shorthand symbols.
You’re absolutely right about the set_float_icon and corresponding method. Coding’s an iterative process and that’s a byproduct. I think set_float_icon()
along with complimentary methods like set_docked_icon(), set_minimize_icon(), set_restore_icon()
etc may be easier to use / remember wtf it does in six months time!
Thanks for the black / ruff suggestion. I’ve never heard fo them, but I’m about to go look for them.
Thanks for your response.
should never embed classes within other classes)
Why is this? I have to admit that coming from other languages, it feels dirty, but is there a pythonic good reason for this? The class ‘belongs’ to the FoldableDockWidget class, so I figure it’s the best place to put it.
This looks awesome - thanks! What’s the all-in price?
Thanks. I wondered why I instinctively text-transformed the title of the widget to uppercase! I commented it out thinking perhaps it doesn’t look grammatically correct! Reduced the font size a bit and I think it looks a heck of a lot better now!
Qt automatically handles the conversion of QDockWidgets into tabbed docked widgets when one is dragged over an existing one.
I have a little demo video, but I have no idea where to upload it to!
Also forgot to point out, you can buy keys with a transparent cover over the top on ali so you can shove a piece of paper underneath the transparent bit to use as labels.
Amateurs. I use butterflies.
I get this, but an IDE should be invisible and grow as you do and not require you to learn lots of janky things before it becomes a little bit useful for you.
Need the basics, great, here they are. Don’t understand some advanced feature? Well the IDE has it here, but it isn’t in your way, mess with it as and when you want. It’ll still be there.
I don’t think one IDE does everything for different languages and its ok to swap editors depending on your workflow, your project and your ever-changing skillset.
I’m using Mate and it allows me to easily define custom shortcuts to open apps and so on. I suppose autoIt / the linux variants / custom script can add additional functionality to the keypad as well!
‘~Esc$&:;()[]{}<>=+*
Other than it being your password, why?
I’m using ch57x-keyboard-tool to configure it
Great! I’ve bought similar without the dials (I wish I didn’t have to pay extra for the stupid LEDs) and was hoping there was something open sourcey to configure it with rather than their dodgy codebase for the same reasons you list!
Awesome! Maybe this should be added to the topic of each language-specific channel?
It sounds beautiful! It’d be really nice if there were transparent rubber keypads available that could be put over phone screens. Then you could fashion an old phone as a keyboard with infinite layers. A simple flutter app to set up the shortcuts and make them configurable and badda boom!
Mechanical keyboards have a huge, fanatical following! /c/mechanical_keyboards - shame it’s dead. I expected to see posts of why the IBM Model M is better than everything else!
I’m really happy that it works for you! Well done on doing the hard work to find it!
I do miss the tags of SVN that would replace certain strings on each commit such as the date, a version number, etc.